Get in touch
Back
Degraded

Stripe has a temporary issuer outage

Started 7 Feb at 12:18pm CET, resolved 7 Feb at 03:25pm CET.

Stripe
Resolved

We're not seeing any errors anymore as caused by the interruption.

Posted 7 Feb at 03:25pm CET.
Created

There are currently problems performing payments from certain credit card issuers with Stripe. They're asking to try payment again with a different payment method, or at a later moment.

Posted 7 Feb at 12:18pm CET.