Get in touch
Back
Downtime

Some services are down

Started 9 Nov at 10:11am CET, resolved 9 Nov at 10:38am CET.

Mollie
Resolved

A fix has been implemented and they are monitoring the results.

Posted 9 Nov at 10:38am CET.
Created

Mollie is currently facing a major disruption affecting payment services, the merchant dashboard and Mollie.com.

You may be unable to create payments, log into the merchant dashboard or connect to Mollie.com.

Check the Mollie status page for updates on this disruption.

Posted 9 Nov at 10:11am CET.